Pan Sharpen Tutorial

Another useful tool Adobe Photoshop provides is the ability to intelligently resample images. Pan sharpening (short for panchromatic sharpening) the use of a single band to increase the spatial resolution of a multispectral image. A multispectral image contains a higher spectral resolution of a panchromatic image, while often a panchromatic image will have a higher spatial resolution than of a multispectral image. A pan sharpened image represents the best of both worlds which is essentially a sensor fusion that gives a multispectral image higher spatial resolution.

1.In Adobe Photoshop, browse to the Landsat 7 Multispectral folder and open the following images:

Band 8 (Panchromatic), 15 meters.tif

Band 1 (Blue-green), 30 meters.tif

Band 2 (Green), 30 meters.tif

Band 3 (Red), 30 meters.tif

In this tutorial, the panchromatic image will be combined with a multispectral image in true colour, however, any false-colour composite combination can be used.

2.From the Window menu, choose Channels to open the Channels panel.

3.In any 30 meter resolution active document window (Band 1, 2 or 3), click Merge Channels in the Channels panel options menu.

information If Band 8 is chosen, Merge Channels will be disabled.

4.In the Merge Channels dialog box, choose RGB Color from the Mode drop-down list and click OK.

5.In the Merge RGB Channels dialog box specify the following channels:

Red: Band 3 (Red), 30 meters.tif

Green: Band 2 (Green), 30 meters.tif

Blue: Band 1 (Blue-green), 30 meters.tif

pansharpen_rgb321

6.Click OK to complete the merge.

pansharpen_rgb321_image

Since the merged image is at 30 meter resolution, it is necessary to resample it to match the resolution of the panchromatic image (15 meter resolution).

7.With the merged document window active, choose Image > Image Size.

8.Ensure Constrain Proportions and Resample Image check boxes are checked. Choose Bicubic (best for smooth gradients) as the resampling method.

9.In the Pixel Dimensions frame, select Percent from the units drop-down list.

10. Enter 200 in the width dimension and click OK.

pansharpen_imageresize

11. From the Image menu, choose Mode > Lab Color.

12. In the Channels panel options menu, click Split Channels.

The merged image is split into three images: Lightness, a and b.

pansharpen_documents

The split images have a “_Lightness”, “_a”, or ,”_b” added to the end of the document name. The a and b channels carry green-red and blue-yellow information respectively. Our process is to substitute the panchromatic image for the Lightness channel.

The following step involves some trial and error. The intent is to make the image brightness and contrast match the Lightness channel as much as possible. Ignore areas of water or vegetation and concentrate on roads and buildings. Often panchromatic images contain data that extend into the infrared, therefore vegetation and areas of water appear differently. The higher resolution of the panchromatic image, the more contrast it will appear to have.

information Ignore vegetation and areas of water because panchromatic images often contain near infrared data.

13. Make Band 8 (panchromatic), 15 meters.tif active and create a Brightness/Contrast adjustment layer. Choose Layer > New Adjustments Layer > Brightness/Contrast. Click OK to accept the default name and settings.

14. In the Brightness/Contrast settings (Adjustment panel), adjust Brightness to 100 and Contrast to 35.

pansharpen_adjustmentpanel

15. Create a second adjustment layer. Choose Layer > New Adjustments Layer > Levels. Click OK to accept the default name and settings.

16. In the Levels settings (Adjustment panel), change the midtone input level to 0.9 and the highlight input level to 230.

pansharpen_levels

17. To properly merge channels, the layers need to be flattened first. Choose Layer > Flatten Image.

18. In the Channels panel options menu, click Merge Channels. In the Merge Channels dialog box, select Lab Color in the Mode drop-down list and click OK.

pansharpen_mergechannels

19. In the Merge Lab Channels dialog box specify the following channels:

Lightness: Band 8 (Panchromatic), 15 meters.tif

a: Untitled-1_a

b: Untitled-1_b

pansharpen_mergelab

information The Untitled documents were created from splitting the channels in step 14. Untitled documents may not be appended with the number 1, however, be sure that the final character corresponds to the channel e.g. a = “Untitled-4_a”.

20. Click OK to complete the merge.

21. Choose Mode > RGB to convert the image back to RGB mode.

22. Leave the document open for the next tutorial.

This exercise is a guide to enhance images for display or printing purposes, this method involves subjective judgment to pixel colour adjustments and should not be used for scientific purposes. The colours of the pan-sharpened image will look different from the original RGB image because panchromatic data (from Landsat 7) extend into the infrared, most notably vegetation and areas of water.

Resample and Sharpen

Adobe Photoshop sharpen filters can increase the detail of the image. The Sharpen filter menu has a variety of sharpening tools. These tools also involve some trial and error to achieve enough sharpening without overdoing it. Two sharpening filters are explained below.

The Unsharp Mask

This filter sharpens an image by increasing contrast along the edges of an image. It locates pixels that differ in value from the surrounding pixels, this option can be modified by changing the threshold. The radius of the region to which each pixel is compared is also an option that can be modified.

Smart Sharpen

This filter has more advanced controls not available in the Unsharp Mask filter. This filter will allow control over the amount of sharpening that occurs in shadow and highlight areas. The document should be viewed at 100% to get an accurate view of the sharpening.

Amount: Sets the amount of sharpening. A higher value increases the contrast between edge pixels, giving the appearance of greater sharpness.

Radius: Determines the number of pixels surrounding the edge pixels affected by the sharpening. The greater the radius value, the wider the edge effects and the more obvious the sharpening.

Remove: Sets the sharpening algorithm used to sharpen the image. Gaussian Blur is the method used by the Unsharp Mask filter. Lens Blur detects the edges and detail in an image, and provides finer sharpening of detail and reduced sharpening halos. Motion Blur attempts to reduce the effects of blur due to camera or subject movement. Set the Angle control if you choose Motion Blur.

Angle: Sets the direction of motion for the Motion Blur option of the Remove control.

More Accurate: Processes the file more slowly for a more accurate removal of blurring.

 

In the Smart Sharpen dialog box, click the Advanced option to display the Shadow and Highlight tabs. Adjust sharpening of dark and light areas using these tabs. If the dark or light sharpening halos appear too strong, reduce them with these controls, which are only available for 8‑bits and 16‑bits-per-channel images:

Fade Amount: Adjusts the amount of sharpening in the highlights or shadows.

Tonal Width: Controls the range of tones in the shadows or highlights that are modified. Move the slider to the left or right to decrease or increase the Tonal Width value. Smaller values restrict the adjustments to only the darker regions for shadow correction and only the lighter regions for highlight correction.

Radius: Controls the size of the area around each pixel that is used to determine whether a pixel is in the shadows or highlights. Moving the slider to the left specifies a smaller area, and moving it to the right specifies a larger area.

1. With the image still open from the previous exercise, choose Filter > Sharpen > Smart Sharpen.

2.Set the following parameters in the Smart Sharpen dialog box:

Amount: 15%

Radius: 2.0 pixels

Reduce Noise (if applicable): 10%

Remove: Lens Blur

Check the More Accurate check box (if applicable)

pansharpen_smartsharpen

3.Click OK.

Features appear to have more detail when compared to the image prior to sharpening. Again, this will involve some trial and error if the results are not satisfactory, experiment with settings if more sharpening is needed.

Copyright © 1995-2015 Avenza Systems. All rights reserved.

 

Last updated: 3/27/2015