My Account     Contact Us     Cart

Reply To: Android 4.4.2 no longer supported

Home Forums Avenza Maps General Android 4.4.2 no longer supported Reply To: Android 4.4.2 no longer supported

#9342
rebecca
Member

Hi Roy,

We do not recommend downloading APKs from the internet. If you download the APK from the internet we cannot be held liable if there are any issues, and we do not support any versions prior to Avenza Maps 3.3 because we do not support Android OS 4.4.

If you decide to download the APK from the internet, the version that you need is Avenza Maps 3.2.

Let me know if you have any other questions!

Best,
Rebecca Bennett
Applications Specialist