My Account     Contact Us     Cart

Geographic Imager Compatibility

Existing Geographic Imager users should not immediately update to Adobe Photoshop CC 2018. A full update to Geographic Imager will be released shortly that will be fully compatible.

Geographic Imager Compatibility by Adobe Photoshop


  • Not compatible with Adobe Photoshop CC 2018. Existing Geographic Imager users should not immediately update to Adobe Photoshop CC 2018. A full update to Geographic Imager will be released shortly that will be fully compatible.

  • * Deprecated in the most current release of Geographic Imager.

  • ** Adobe Photoshop CC 2014.1, 2014.2, and 2014.2.1 for Mac have a compatibility issue with Geographic Imager. Read about the issue here.

  • *** Geographic Imager versions 4.3 to 4.5 are no longer supported in Adobe Photoshop CS5 and CS6 due to an Adobe certificate signing issue. Read about the issue here.

  • Contact your local Avenza reseller before purchasing Geographic Imager if you intend to use it with a non-English version Adobe Photoshop.

  • See the latest Geographic Imager system requirements.

  • See list of Geographic Imager supported formats.

Geographic Imager

Adobe Photoshop

CC 2018CC 2017CC 2015.5CC 2015CC 2014CCCS6CS5
5.2
5.1*
5.0**
4.5********
4.3 & 4.4******

Geographic Imager Compatibility by Operating System


  • Contact us if you require information about older versions of Geographic Imager.

Geographic Imager

Operating System

WindowsMac
1087VistaXP10.1210.1110.1010.910.810.7
5.2
5.0 & 5.1
4.5
4.3 & 4.4
4.2

Get Help

Get Help

Get started with Geographic Imager online help including tutorials and data.

Go to Support Centre


Get Tricks and Tips

Read up on Geographic Imager tricks and tips on the Avenza Resources Blog.

Go to Resources Blog
Demo

Live Demo

Request a live online Geographic Imager demo with us. We’re here to answer all your questions about it.

Book a demo