Chart themes come in two types: bar chart and pie chart. A bar chart is represented by rectangular bars with lengths proportional to the attribute values that they represent. A pie chart is comprised of a circle divided into sectors, showing attribute value proportion. These charts are generally placed near the center of the aggregation area (e.g. census tract or state).

Chart data is read from attributes from a MAP Layer and MAP Themes quickly styles the data using Adobe Illustrator symbols and graphic styles. Charts can plot both discrete and continuous data. Some examples of discrete data include voters or hair color. Some examples of continuous data would be temperature or height.

Using Chart Themes

Create New Chart Theme

To create a new Chart theme, click the Add Map Theme button in the MAP Themes panel. Alternatively, choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, where the theme name, theme type, and feature type for a new Dot Density theme are specified.

new_charttheme

Chart themes are displayed in the MAP Themes panel. To edit a Chart theme, double-click it or select  Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Chart Theme dialog box.

maptheme_charttheme

Chart Theme Editor

The Edit Chart Theme dialog box is where the chart type, style and its options are chosen:

editchart_theme

The Theme name is reflected in the MAP Themes panel and can be edited. Specify either Bar chart or Pie chart from the Type drop-down list. Depending on the type of chart chosen, several appearance and option settings will differ.

 

Choose the appropriate Legend layer to store the charts from the Output layer drop-down list. Enable the Ignore option and enter an expression (or use the Expression Builder or Library) to specify data values that will be ignored.

Add Source Data

In the Source Data tab, choose a MAP Layer to load its attributes from the Layer drop-down list (Text layers are not supported). Only the attributes of a single layer may be chosen at a time (meaning mixing layers and attributes is simultaneously is not possible). Click the Add attribute button to add an Unspecified attribute slot into the list. Select an <Unspecified> item in the list and choose an attribute from the Attribute drop-down list. The attribute name is automatically used in the Label box, however it can be edited. Any changes to label and appearance are reflected in the attribute list as well as the chart preview. To change the sort order, select an attribute in the list and click the Up or Down arrow.

Adjust Bar Chart Appearance and Options

To change the appearance of an attribute, select one from the list to enable its appearance properties. The Appearance section, in Custom Mode (default), has adjustments for stroke, stroke opacity, stroke width, fill and fill opacity. Alternatively, click the Toggle Mode button to switch to the Graphic Style Mode. In that mode, choose a predefined graphic style from the drop-down list (sourced from the Graphic Styles panel). Changes made are reflected in the style indicator in the attribute list as well as the chart preview at the bottom of the dialog box.

chartoptions_source

In the Chart Options tab, adjust basic bar chart settings—width, height, bar orientation and bar spacing. Other options include setting the bars relative to maximum data value. In this case, all the bar values are divided by the maximum value and then drawn as a relative proportion to it. For point layers, an alignment control is available to position the chart.

chartoptions

In the General Options tab, enable the Apply style to chart option to choose a predefined style. The Sort Values option sorts (from left to right) increasing and decreasing values (not shown in the chart preview). The Draw chart border option is not enabled by default; click the check box to enable it and adjust its appearance options.

general_options_tab

Adjust Pie Chart Appearance and Options

The Pie Chart Appearance options differ slightly from the Bar Chart options. Only the options applicable to pie charts are shown here. The other Appearance options function identically as explained in the previous section. The Explode option creates separation of a selected attribute (slice) from the rest of the pie chart. To adjust the separation of all slices, use the Explode option in the Options section.

edit_charttheme_pie

In the Chart Options tab, adjust basic pie chart settings—pie radius, hole radius, explode and rotation. The Hole Radius option creates a hole in the middle of the pie chart and results in chart that looks like a ring. The Explode option here is different than the attribute Explode option in that this applies to all the slices and not just a single slice. The Rotation (default at 0) starts at the top (12:00 o'clock position) of the pie chart and rotates clockwise (negative rotation values cannot be used) up 359 degrees.

 

The General Options function identically as explained in the previous section with the addition of pie chart specific settings.

pie_chart_options

For any adjustable size, distance or length setting, choose the appropriate units from the Units drop-down. For pie charts, an option to scale by area or radius is available. See more about chart scaling.

Chart Labeling

There are multiple options to label both bar and pie charts. In the Edit Chart Theme dialog box, the Title and Labels tabs contain labeling settings. By default, all labeling options are disabled. Click the check box beside Show title, Show attribute value labels and Show attribute name labels to enable labeling options for each one. The Show attribute name labels option only applies to bar charts. The labeling options are shown below with an example of what some of the settings do.

chart_title_tab

Click the Appearance text link to edit labels in the Edit Text Rendition dialog box. Click the Rendition toggle to choose a predefined character style in Character Style mode or set appearance options in Custom mode.

edit_text_appearance edit_text_appearance_character

Custom mode (left) vs Character Style mode (right)

Chart Scaling

There are multiple options to adjust how charts are scaled. In the Edit Chart Theme dialog box, click the Scaling button to access the Scaling dialog box. There are two options to scale charts: fixed size or use a value from an attribute. The fixed size option scales all the charts equally by the set percentage. From the initial size, a scale above 100% increases chart size and a scale below 100% decreases chart size.

 

To scale from attribute, click the attribute drop-down list and choose the appropriate attribute. Click the Load button to load the data range so that the Scaling dialog box knows which values to use. When the data range values are clicked, they populate the boxes below (Normalize and Tie to value).

 

Use the perceptual scaling option to create a more visually accurate depiction of the scale. Perceptual scaling modifies the scaling slightly in a way that tends to make users perceive the relationship between scaled symbols as intended. When checked, the scaling will not be mathematically accurate but should be viewed as visually accurate.

chart_scaling

Use the Attribute value is scale percentage option to scale the charts directly using the values for the selected attribute. The maximum scale value allowed is 999 percent. Any values that do not conform will be marked by the MAP Themes Log as an error and the scale for that chart will not be applied.

 

Use the Normalize option to set a value as 100 percent. All other values are converted to a percentage based on the set value and used to scale the charts. For example, if an attribute has a value of 2000 to be normalized as 100 percent, that means a value of 1500 will be considered as 75 percent, effectively reducing the size of the chart.

 

The Attribute value determines scale from range option contains a number of setting to fine tune how the scale is set based on a range of values. The settings of the Minimum (default 5%) and the Maximum (default 100%) are based on the minimum and maximum of the data range. The Tie to value box specifically states which value in the range that is set as the Minimum or Maximum. It has two options available where any values below (minimum) or above (maximum) can be discarded or bound. This may be useful if there are extreme low or high values that could affect the scaling.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 4/10/2019