Create Bar Chart Theme

1.Create a new Adobe Illustrator document.

2.Import canada.shp from the Tutorial Data folder.

3.In the MAP Themes panel option menu, click New MAP Theme. In the New MAP Theme dialog box, type Population into the Theme Name box, select Chart as the theme type, and click OK.

them_type_chart

4.Double-click the Population chart theme in the MAP Themes Panel. Click Create Legend layer when the message appears to say a Legend MAP Layer is required.

5.In the Edit Chart Theme dialog box, select Bar Chart from the Type drop-down list.

6.Check the "Ignore" check box and enter in the following expression: LIKE(NAME,"Yukon") OR LIKE(NAME,"Nunavut") OR  LIKE(NAME,"Northwest Territories"). This will prevent bar charts from being applied to Canada's far north.

7.In the Source Data tab, with canada_area selected in the Layer drop-down list, click the Add button twice to add two attributes.

8.Highlight the first unspecified attribute. In the Attribute drop-down list, select POP2001. In the Appearance section choose a Fill color and set the stroke to None.

9.Repeat these steps with the second unspecified attribute highlighted, this time using the POP2010 attribute and a different color for the chart bar (and no stroke).

barchart

10. In the Chart Options tab, change the Bar thickness to 10, Maximum bar length to 80, and Bar spacing to 4.

barchart2

11. In the Title tab, click the Show title check box. Enter Pop as the title in the Specify box.

barchart3

12. In the Labels tab, click the Show attribute value labels check box. Change the rotation value to 90 and click the Appearance text style link.

13. In the Edit Text Appearance dialog box change the text size to 8.00 pt and click OK.

14. Click the Align value labels check box.

15. Enable the Show attribute name labels check box. Change the text size to 8.00 pt and set a Rotation of 45.

barchart4

16. Click Apply to apply the theme to the map.

17. Select the newly created charts and go to Object > Transform > Transform Each. Adjust the horizontal and vertical scale to both 30% and click OK.

barchart_done

18. Close the document without saving.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 12/11/2020