Exporting to Geospatial PDF

1.Open usa48.ai from the Tutorial Data folder.

2.From the MAPublisher Toolbar, click the Export button > Export Document to Geospatial PDF. In the Content tab, ensure that the usa_area check box is checked.

3.Click the Layer List & Model Tree tab. Click usa_area to enable its options. Click the Use attribute for feature name check box. The Attribute drop-down list is STATE_NAME.

geopdfsettings

This setting will use the attributes of STATE_NAME, in an ascending sort order, in the Model Tree. In the Options tab, leave the Embed AI file within PDF as checked. This ensures that the geospatial PDF can be read properly if it is ever imported into Adobe Illustrator using MAPublisher.

4.Click the Export button. In the Export dialog box, choose Geospatial PDF from the Save as type drop-down list. Navigate to the Tutorial Data directory, specify the file name as usa.pdf and click Save.

exportsave

5.Open the operating system file browser window and navigate to the Tutorial Data folder.

6.Double-click to open usa.pdf in Adobe Acrobat Reader (the latest version is required).

acrobatwindow

The latest Acrobat Reader supports geospatial PDF files and comes with tools to explore the map. The Analyze toolbar is located in the Tools menu. It holds three tools specific to geospatial PDFs: Object Data Tool, Measuring Tool and Geospatial Location Tool. On the left hand side, there are two useful Navigation panels related to geospatial PDFs: Layers and Model Tree. There are also Acrobat Reader preferences to change display elements such as geographic units.

7.Click the Layers button in the Navigation panel to expand it. (If it is not present, right-click the Navigation panel and choose Layers.)

acrobatlayers

Only the usa_area layer is present in this geospatial PDF. The layer's visibility can be controlled by clicking the eye icon.

8.Click the Model Tree in the Navigation panel to expand it. (If it is not present, right-click the Navigation panel and choose Layers.) Click the + symbol beside usa_area to expand it. Click a state to view its relative location on the map. Alternatively, use the Object Data Tool and click features on the map.

acrobatmodeltree

The Model Tree shows the map features of all the layers in the document. At the bottom of the Model Tree is a window that displays attribute data. In this case, the state name for the feature selected is California.

9.Click Tools, click Analyze, then click the Geospatial Location Tool. (If it is not present, click the Tools panel options menu, then click Analyze.) A status window appears in the bottom-right corner that displays the longitude and latitude of the cursor position.

acrobatlocationtool

10. In the Analyze menu, click the Measuring Tool. Click and drag anywhere on the map and draw a measurement line (if necessary, zoom in to see the features in more detail.)

acrobatmeasuring

When the Measurement Tool is enabled, a secondary measurement toolbar appears that contains Snap Types and Measurement Types. A status window in the bottom-right corner appears that displays information on the distance measured, azimuth, latitude and longitude of the cursor position. In this case, the straight line distance from Portland to Kansas is approximately 1218 miles (or about 1,960 km).

11. In the Acrobat Reader menu, click Edit > Preferences. In the Categories list, click Measuring (Geo).

geospatialpdf_preferences

This dialog box is used to change geospatial measuring options. See the MAPublisher User Guide for detailed information on all of its options and settings.

12. In the Display value as drop-down list, select Degrees, Minutes, Seconds.

13. In the Use default distance unit drop-down list, select Miles.

acrobatpreferences2

14. Click OK to accept these settings.

15. Using the Measure Tool, choose several points to measure.

acrobatmeasuring2

Notice that the distance is displayed in miles (mi) and that the coordinates are now displayed as Degrees, Minutes, Seconds. Return to the Measuring (Geo) preferences to experiment with the settings to see how they can help you explore geospatial PDF maps.

16. Close the geospatial PDF document without saving.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 10/8/2019