Requirements

Points can only be plotted on MAP Point layers. The coordinate system of a MAP View can be used to calculate where points and addresses are plotted. The plot button is disabled when another MAP layer type is active.

Symbol Selection Setup

The symbols used by MAP Point Plotter are a direct reproduction of those that exist in the Adobe Illustrator Symbols panel. To open the Adobe Illustrator Symbols panel, click the menu Window > Symbols. To add symbols to the Symbols panel, create symbols as closed Adobe Illustrator objects and drag them into the panel. Alternatively, open the Symbols panel, click the panel options menu > Open Symbols Library > MAP Symbols > MAP - Symbols. The MAP - Symbols.ai file from the Helpful Styles & Symbols folder is installed with MAPublisher.

Using Point Plotter

Click the MAP Point Plotter button on the MAPublisher toolbar or from the menu Object > Window > MAPublisher > MAP Point Plotter.

mappointplotter_panel

Choose a Symbol and Scale

Select an appropriate point symbol by clicking the symbol name link. The symbols displayed are the symbols that currently exist in the Adobe Illustrator Symbols panel. To scale the symbol used, edit the percentage value in the Scale box. Clicking the Up and Down arrows will increase or decrease the value by 10%.

select_symbol

information When a MAP Themes stylesheet is assigned to a Point layer, it will override the map symbol chosen in the MAP Point Plotter panel.

Enter Coordinates

In the Coordinates tab, when the Use Current Layer's coordinate system option is chosen, coordinate values can be entered in map units of the current MAP View coordinate system. When the Use: WGS 84 option is chosen, the coordinate system link enabled. Click the coordinate system link to open the Select Coordinate System dialog box to choose an appropriate coordinate system.

 

When the selected or default coordinate system is projected, enter X and Y coordinates as map units of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is geodetic, enter Lat and Long coordinates as degrees in the following formats:

Decimal degrees (D+[.d*])

Delimited Degrees Minutes Seconds (D+ MM SS[.s*])

Degrees.Minutes (D+.MM)

Degrees.MinutesSeconds (D+.MMSS[s*])

Packed DMS with decimal point((D)DDMMSS[.s*])

Packed DMS ((D)DDMMSS[s*])

information Items in [ ] are optional, * means zero or more digits, + means one or more digits. Lines of latitude run East-West (the Equator is an example), whereas lines of longitude run North-South (the Greenwich Meridian is an example). Positive degree values represent north latitudes and east longitudes. Negative degree values represent south latitudes and west longitudes. Directions can be entered either with positive/negative values or using the N, S, E or W letters preceding or following the numerical values, separated or not with a space.
 
Valid delimiters for Delimited Degrees Minutes Seconds format are:
• space, hyphen (-), colons (:) or underscore (_), e.g. 43 41 48.98N, 43-41-48.98N, 43:41:48.98N or 43_41_48.98N
• d (degree), single quote (minute), double quote (second), e.g. 43d41'48.98"N
 
Packed formats require the use of two digits for degrees of latitude (e.g. 1°N must be written 01) and 3 digits for degrees of longitude (e.g. 1°E must be written 001).

 

Degrees coordinate format examples:

degrees_coordinate_format

information Double-quotes (") are supported in MAP Point Plotter, but not in the import of Delimited Text.

Enter Address

Use this feature to plot points using a physical address. Only one address can be plotted at a time. To plot multiple addresses at a time, use Plot Addresses From File. Available geocoding sources are MapQuest and ArcGIS Online. An account is required for ArcGIS Online geocoding and uses service credits per address geocoded. See more about ArcGIS Online service credits.

 

In the Address tab, enter a valid address into the Address box. The address should follow a specific-to-general granularity format (e.g. 1155 Burnaby St, Vancouver, British Columbia, Canada).  Attribute data accompanying the address point may be added to the current point layer.

enter_address

information Some international addresses may have to be modified to follow the specific-to-general granularity format.

information Data returned by these services are subject to user verification for accuracy and correctness.

Plot Points and Addresses

Click Plot to plot the coordinate or address point in the designated MAP layer. To plot subsequent points, edit the coordinates or address, and if required, choose different symbols and click Plot again.

Plot Centroids

Plot Centroids adds point symbols at the center of polygons or lines, while copying the attributes from the source MAP layer when the New Layer option is selected. This function is useful for cartographic generalization purposes (e.g. replacing small island area by a symbol) or to simply add a meaningful symbol at the center of areas. For single lines, the centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the largest polygon or longest line is used.

information The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor Points function (Object > Path > Add Anchor Points) before running Plot Centroids on Bezier polygons.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded in the Adobe Illustrator Symbols panel to use them.

Using Plot Centroids

Plot Centroids is located in the MAP Point Plotter panel options menu.

plot_centroids

Choose the MAP View that contains the layers whose centroids are to be plotted

Choose the Source Layer containing the polygons or lines for which the centroids will be based upon

Choose the Destination Layer, an existing Point layer or create a new one, to store the centroids

Choose the symbol Style and Scale to apply.

The High accuracy placement option makes more advanced calculations for the centroid positions to force them to fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands).

information When the New Layer option is enabled, the attributes from the source MAP layer are copied to the new Point layer. However, when using an existing point layer, attributes do not get transferred unless the Point layer was created with its attribute schema based on the same source MAP Layer (see more information on the Base attribute schema on option when creating new MAP layers).

Results

Symbols are added to the specified Point MAP Layer. Depending on the type of polygon or line (single or compound path), symbols are located on the center of the polygons/lines or at the center of the biggest polygon/longest line of a group.

centroids_result

Plot MAP Locations

Plot MAP Locations adds point symbols at positions of MAP Locations. This is useful for reference purposes or to simply add a symbol at MAP Locations.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded in the Adobe Illustrator Symbols panel to use them.

Using Plot MAP Locations

Click the MAP Point Plotter panel options menu and choose Plot MAP Locations.

plot_maplocations_dialog

Select at least one MAP Location to plot in the list

Choose a Destination MAP View to store the Point layer

Specify a new Point layer name or choose an existing layer for which the MAP Locations will be plotted

Select the Symbol and Scale to apply.

Results

Points are plotted where MAP Locations are positioned. The MAP Locations are maintained.

plot_maplocations

Plot Addresses From File

Plot Addresses From File adds point symbols to addresses specified in a file (TXT, CSV, TSV, XLS, DBF). Available geocoding sources are MapQuest and ArcGIS Online. An account is required for ArcGIS Online geocoding and uses service credits per address geocoded. See more about ArcGIS Online service credits.

Using Plot Addresses From File

Ensure a MAP point layer must be selected and click the MAP Point Plotter panel options menu and choose Plot Addresses From File.

plotaddressesfromfile_dialog

Choose a Format (TXT, CSV, TSV, XLS, DBF) from the drop-down and Browse for a file containing the addresses. If a Microsoft Excel file is selected, use the Worksheet drop-down list to specify the sheet that contains the addresses. Depending on the separator used in the file, you may need to change the Separator (comma, tab, semicolon or colon).

 

When the Use first line as a header option is checked, it will populate the Address column drop-down if names exist on the first line of the specified file. Select the appropriate column containing the addresses.

 

Choose from MapQuest or ArcGIS Online to geocode addresses from the file. You will need to register for a MapQuest key to use their geocode service. Note that ArcGIS Online geocoding uses service credits per address geocoded.

 

information Some international addresses may have to be modified to follow the specific-to-general granularity format.

information Data returned by these services are subject to user verification for accuracy and correctness.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 10/15/2019