The MAP Views panel displays a list of all the Adobe Illustrator layers in the current document and all MAP Views—defined configurations for geospatial parameters (coordinate system, anchors, map scale and rotation). Every MAP Layer is shown in this panel as belonging to a particular MAP View. Adobe Illustrator layers that do not have georeferencing information (e.g. non-map objects such as diagrams and supplemental art) are placed in the [Non-MAP layers] category.

MAP Views are designed to give easy access to settings for specifying and transforming coordinate systems, for editing scale and data placement on the page and for exporting to GIS formats. The MAP Views panel allows toggling Adobe Illustrator layers accessibility, georeferencing existing Adobe Illustrator artwork, changing multiple layer names and projecting data on the fly.

Categories on the MAP View panel are symbolized in the following manner:

mapview_icon

MAP View

Contains MAP layers with georeferenced and attribute information.

nonmaplayer_icon

Non-MAP layer

Contains layers without georeferenced or attribute information.

Using the MAP Views Panel

mapviewpanel

Creating New MAP Views

To create a new MAP View, click New MAP View in the panel options menu. This opens the MAP View Editor (discussed in MAP View Editor section). Specify a coordinate system and enter values for scale, rotation, and page anchors. After creating a new MAP View, the Specify Anchors item from the MAP Views panel options menu must be used to define the tie-in point between Map Anchors and Page Anchors.

information Creating a new MAP View is only recommended when registering a non-referenced Adobe Illustrator document. To transform an existing MAP View to a new coordinate system and scale (e.g. to create an inset map), use the duplicate MAP View function and transform or rescale the copied MAP View.

Duplicate And Delete MAP Views

MAP Views can be duplicated. For example, to create inset maps make a duplicate and drag MAP Layers into the new MAP View. Then use the MAP View Editor to edit the placement, scale or coordinate system of the duplicate. Note that MAP Layers can only be duplicated in the Adobe Illustrator Layers panel.

 

Delete a MAP View or MAP Layer using the Delete button at the base of the panel or through the MAP Views panel options menu. When deleting a MAP View, any MAP layers (and sublayers) within it are also deleted.

Create New MAP Layers

Create new MAP Layers to hold geospatial data or to generate artwork using MAPublisher tools (plot points, labels, legends, grids, scale bars and north arrows). Click the Add MAP Layer button to create a new Adobe Illustrator layer which simultaneously places it into a selected MAP View. Specify the appropriate Layer name and Feature type for the new layer.  

add_new_maplayr

 

Below are examples of the types of MAPublisher tools that require a specific MAP Layer type:

 

area_icon

Area layer

For county boundaries, urban areas, country outlines, etc. (Buffer Art, Join Areas, Line Plotter)

line_icon

Line layer

For rivers, roads, railways, etc. (Buffer Art, Join Lines, Line Plotter)

point_icon

Point layer

For town and city symbols, railway stations, etc. (MAP Point Plotter, Join Points)

text_icon

Text layer

For text labels (Label Features, MAP Tagger Tool, MAPublisher LabelPro)

legend_icon

Legend layer

For MAPublisher Legend items (North Arrows, Scale Bars, Grids and Graticules)

image_icon

Image layer

For referenced images (Import Image, Register Image)

 

information The Advanced option Base attribute schema on will copy the attribute schema from an existing MAP Layer. This option is required to enable the copying of attributes from source to destination layers in the MAPublisher labeling tools and Plot Centroids function.

Data Links Notification

When a data source is missing, a notification in the MAP View panel will display. To fix missing sources, click the notification icon and set a new dataset path to correct it. See Manage Data Links.

mapview_missingsources

MAP Views Panel Options Menu

mapviewpanel_optionsmenu

New MAP View

Create a new MAP View and specify its name and coordinate information.

New MAP View For Photoshop Paths

Specify a new MAP View based on paths exported from Geographic Imager/Adobe Photoshop.

Duplicate Selection

Create a duplicate of the currently selected MAP View or MAP layer.

Edit Selection

Open the MAP View Editor to edit the name and coordinate system of the currently selected MAP View.

Delete Selection

Delete the currently selected MAP View or MAP Layer provided it does not contain any Adobe Illustrator layers.

Add MAP Layer

Create a new MAP Layer through Add MAP Layer dialog box.

Specify Anchors

Manually establish the tie-in point between Map and Page Anchors (should only be used for new MAP Views or for the correction of georeferencing errors).

Export Coordinate System to File

Exports the selected MAP View coordinate system to a WKT definition (wkt).

Export Selection

Enable the export of the selected MAP View or MAP Layer to various GIS formats.

Layer Name Search & Replace

Search for text within layer names and specify an alternative. Useful for multi-layer imports.

Sort Art on Layer

Sort art in ascending or descending order based on attribute.

Edit Layer Note

Add or edit the selected layer's note.

Manage Data Links

Open the Manage Data Links dialog box to manage links to data sources.

Load Custom Coordinate Systems

Load external coordinate systems in XML format.

Document Summary

View a summary of all features and other art on both MAP layers and non-MAP layers.

Specify Alternate Coordinate System

Choose a coordinate system that appears as an alternate option on many MAPublisher tools.

Edit Custom Coordinate Systems

Open the custom coordinate system editor to create new coordinate systems and edit the parameters of existing ones in the data source.

Copy MAP Objects From

Copy MAP Views, MAP layers, MAP Themes (including Stylesheets), and MAP Selection Filters from other open documents.

Preferences

Opens MAPublisher Preferences on the MAP Views Panel property sheet.

Transform MAP Layer Coordinate System using the MAP Views Panel

The MAP Views panel can be used to move MAP layers from one MAP View to another, also known as projecting vector data-on-the fly (raster images cannot be reprojected or transformed with MAPublisher). To move a MAP layer to another MAP view, click and drag or use the Switch MAP View button. For example, to reproject a layer that has a UTM projection into a Lat/Long projection, click and drag it from the MAP View with a UTM projection and drop it into the MAP View with a Lat/Long projection. MAPublisher will automatically transform and scale artwork to match the destination MAP View. The Missing Coordinate System dialog box appears when neither the origin nor destination MAP View contains a defined coordinate system.

missing_coordinatesystem

Two options are available in this dialog box:

Specify coordinate system: specify projection using the Source Coordinate System function.

Same as: specify coordinate system based on an existing MAP View in the document.

information Many coordinate system transformations will inherently cause the loss of precision by the very nature of complex mathematical calculations that must be performed. As a result, please be aware that some precision may be lost if layers are dragged repeatedly from one coordinate system to another. When determining a coordinate system to use via the drag method, we strongly recommend Edit > Undo to revert back until the appropriate system is found.

Assign Georeferencing Information to Adobe Illustrator Layers

Existing Adobe Illustrator layers that do not contain georeferencing or attribute information also appear in this panel under the default MAP View entitled [Non-MAP layers]. Such layers can be moved into a specified MAP View with a matching geospatial configuration (coordinate system, scale, position on the page, etc.).

 

Moving a non-MAP layer into a specified MAP View prompts the Undefined Layer dialog box. Use it to specify the feature type of the moved layer. Multiple layers may be selected and moved together to a specified MAP View. Use the Apply to all option to assign the same feature type to all layers being moved. The Base attribute schema on option copies the attribute schema from an existing MAP Layer.

undefined_layer

information Moving a non-MAP layer to a MAP View does not imply any transformation (the artwork is not redrawn). Ensure that the art on the non-MAP layer is positioned and scaled properly on the page with regard to the MAP View definition.

Specify Anchors

The Specify Anchors function should only be accessed when referencing a new MAP View (for example in the process of georeferencing an Adobe Illustrator file) or to correct an inaccurate referencing.

specify_anchors

When the Use Current MAP View's coordinate system option is chosen, Map Anchor coordinate values are entered in the map units of the coordinate system of the MAP View. Map Anchor coordinates must be known from information written on the map (e.g. graticule crossings) or from external sources (metadata, survey points or other). MAP World Locations can be used as Map Anchors.

 

When the Use: [coordinate system] option is chosen, the current coordinate system link is enabled. Click it to open the Select Coordinate System dialog box. The coordinates values entered will be in the unit (Point Style) of the chosen coordinate system. When the selected or default coordinate system is projected, X and Y coordinates are entered in the unit (Point Style) of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is Geodetic, Lat and Long coordinates are entered in degrees.

 

information When the current MAP View coordinate system is a projected system, the default system specified in Use: [coordinate system] is set to the geodetic system base for the projection. For example, if the MAP View system is US State Plane NAD83 / Colorado North (ftUS), the default alternative system is set to NAD83 (to enter the latitude/longitude coordinates in degrees).

 

The Page Anchor is entered in the current unit of the document. This unit can be changed through the Adobe Illustrator menu File > Document Setup. Positions of points on the document in page coordinates are determined using the Adobe Illustrator Info panel (menu Window > Info). MAP Page Locations can be used as page anchors.

Layer Name Search & Replace

To quickly change the names of multiple Adobe Illustrator layers, use the Layer Name Search & Replace function located in the MAP Views panel options menu. For example, MicroStation Design or CAD imports can contain a large number of similarly named layers and doing a name search and replace is more efficient than manually changing each of them.

layername_search_replace

information Search terms are case sensitive.

Zoom to MAP Layer or to MAP View

To zoom to a MAP Layer, select one and click the Layers Operations button at the bottom of the MAP Views panel. Click Zoom to "[Layer]" in the context menu. When a MAP View is selected, this option becomes Zoom to all layers in "[MAP View]". This is particularly useful for documents containing a large number of layers.

Layers Operations

The Layer Operations button will perform a variety of layer operations. If a MAP Layer is selected, use the context menu to Lock, Unlock, Hide or Show "[Layer]" or to Lock, Unlock, Hide or Show all layers except "[Layer]". If a MAP View is selected, the same options become for all layers in "[MAP View]" or all layers except layers in "[MAP View]".

MAP Layer Note

MAP Layer Notes contain general information about the layer, such as how it was created or on its source data. MAP Layers with no layer notes are marked with an Add Note icon. To add or edit a layer note, choose the MAP Views panel options menu Edit Layer Note. In the Add/Edit Layer Note dialog box, type new text or edit the existing information. Click the Clear button to clear all information.

map_layer_note

Layer notes can be automatically added when the layers are created through MAPublisher functions (e.g. MAP Data Import, Plot Centroids, Web Feature/Map Service, etc.). To do so, enable the MAPublisher General Preferences Add notes options for layers created by MAPublisher operations. The automatic notes show the function and parameters used to create it. For example a note of a layer created by import indicates information such as the path of the source data, format and date.

Export MAP Views and MAP Layers

The MAP Views panel offers the option to export a single MAP View or a single MAP Layer to a multitude of GIS formats. See more about exporting MAP Views and MAP Layers.

New MAP View For Photoshop Paths

The New MAP View For Photoshop Paths function creates a new MAP View using a reference file and associated Adobe Illustrator file exported from Geographic Imager for Adobe Photoshop.

new_map_view_photoshop

Adobe Photoshop offers a function to create vector paths and export them to Adobe Illustrator. Adobe Photoshop uses Geographic Imager to maintain the spatial reference and outputs it as an RSF reference file. To import the paths into Adobe Illustrator using MAPublisher, use the New MAP View For Photoshop Paths from the MAP View panel options menu to create a new MAP View based on the RSF file. After doing this, the Adobe Illustrator layers can simply be dragged from [Non MAP Layers] to the newly created MAP View to finalize the georeferencing. The vector data can now be used in a current MAPublisher project, edited, transformed or exported to any external GIS format.

Remove MAPublisher Information

At the end of a project cycle, it may be useful to permanently remove all georeferencing and attribute information in the current document. This can be accomplished by switching all MAP Layers to the [Non-MAP layers] category in the MAP Views panel via drag and drop or clicking the Switch Map View button and the Remove MAP data option.

 

information This function should only be used as required and as a final step. Be sure to save a copy of the document before performing this operation as this will erase all attribute data.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 4/5/2019