Register Image applies geospatial referencing to images imported to the artboard. Register Image uses a coordinate system and coordinates—entered manually or loaded from a reference file—to properly georeference and scale an image. If the coordinate system of an image matches one of existing vector data, the image can be scaled and rotated to fit with the vector data. If no matching vector data is found in the document, a new MAP view can be created to store the cartographic information of the image to allow for data digitization with accurate positioning.

information Register Image does not have the capability to transform images from one coordinate system to another. Use a product like Avenza Geographic Imager to transform images.

Requirements

To use Register Image, the geospatial properties of the raster image must be known. Some raster image formats store the relationship between source image coordinates (pixel location) and real-world reference coordinates in an associated reference file but do not save the coordinate system information (e.g. TFW world file). The commonly used GeoTIFF format is embedded with geographic information such as position and coordinate system. Depending on the image format, check the position and coordinate system of imagery with the data provider before attempting to use this tool.

Register Image can be used on non-spatially referenced images that are already imported to the artboard using the Adobe Illustrator Place command (File > Place) or through Import as an Image feature type.

information When placing an image, do not use the Convert Layers to Objects option. It will treat images that may have multiple layers as grouped objects and will prevent it from being registered properly.

information Using an embedded, unflattened image with an existing transparency may result in incorrect registration.

Using Register Image

With an image selected, click the Register Image button on the MAPublisher toolbar or from the menu Object > MAPublisher > Register Image.

If the image is placed on a MAP Layer, the Register Image automatically registers the image using the coordinate system of the MAP View containing that MAP Layer.

If the raster image was not imported to a MAP Layer, the Undefined Layer dialog box will appear. Choose either to create a new MAP View based on the image or choose to add the image to an existing MAP View. In either case, the Image feature type is the only one available for rasters. It is recommended to use the Image feature type for image registration and for better layer management and workflow.

When creating a new MAP View, the anchor point and scale are derived from the registration information (placement and image size). In the case of GeoTIFF images, the MAP View coordinate system is automatically read from the image header—for other image formats, the coordinate system has to be specified manually in the MAP View Editor after the registration process (see more information on Specify coordinate system).

Registration using Reference File

To register an image using a reference file, click the Load File button and navigate to the folder containing the file. The reference file may have the same name as the image, but may have a different extension (IRP, TFW, TAB, RSF, ERS or LGO). In the case of the GeoTIFF format, the image file itself contains both the image and reference data and the needs to be chosen to retrieve the georeferencing information.

 

The values contained in this reference file are automatically entered into the image parameters. If the file is in GeoTIFF format, the image coordinate system is read and displayed under Reference File Coordinate System—for other file formats, the coordinate system is left as unknown.

Manual Registration

To manually enter image parameters, one of the following combinations must be available in page units or map units:

The X and Y coordinates of one corner of the image and the X and Y Pixel Size.

The X and Y coordinates of one corner of the image and the X and Y size of the image.

 

First choose the units to use for entering parameters by making a selection from the Units drop-down list. Then, click the appropriate corner of the graphic to indicate the image placement point and enter the X and Y coordinates for this location in the adjacent fields. Next set either the Pixel Size or Effective Map Size. The Pixel Size is the value of a single pixel in the units set. The Effective Map Size is the X and Y size of the whole image in the units set. Setting either option will update the other accordingly.

information MAPublisher Register Image supports the registration of images having non-square pixels.

Results

When registering GeoTIFF images, a warning message will be displayed if the coordinate system of the image does not match the selected MAP View's coordinate system. When registering images not in GeoTIFF format while creating a new MAP View, the coordinate system of the MAP View has to be specified in the MAP View Editor to finalize the georeferencing.

Provided that the coordinate system, placement and size of the raster image are correct, the image will be scaled and registered. When matching vector data is available, the image will fit to the artwork. The MAP Location Tool can be used to check the positions.

information Raster images cannot be transformed into another coordinate system. If the vector data is transformed through the MAP View Editor Perform Coordinate System Transformation function after the image has been register, the image will have to be transformed externally (with Avenza Geographic Imager for example) and registered again in MAPublisher.

information Registered images will be scaled and rotated together with the vector data, but not automatically. After the vector data has been scaled or rotated using the MAP View Editor, Register Image must be used to apply the image referencing information. In the case of a manual registration, it is recommended to use the Export Image function before applying the changes to the vector data (see next paragraph). This way, registering the image again is only a matter of loading a reference file.

Supported Georeferenced Image Reference Formats

World File (tfw, tifw, wld, eww, jgw, jpw, pgw, sdw, eww, blw, dmw)

World files contain the affine relationship between source image coordinates (pixel locations) and real-world reference coordinates (lat/long or other real-world coordinate units). World files simply contain a computed relationship between source image coordinates and reference coordinates and not the complete reference point information. World files do not support storing coordinate system information.

IRP Image Report File (irp)

IRP Image Report files are ASCII report files indicating the coordinates of the four corners of the raster file and the pixel size in ground units to allow for georeferencing of the image in other image processing, CAD, or GIS programs.

MapInfo Table File (tab)

MapInfo Table file formats save the complete reference point list information such that it can be loaded again in the future. MapInfo TAB files support storing coordinate system information.

 

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area

Azimuthal Equidistant

Cylindrical Equal Area*

Eckert IV*

Eckert VI*

Equidistant Conic*

Gall Stereographic*

Hotine Oblique Mercator

Lambert Azimuthal Equal Area*

Lambert Conic Conformal

Mercator*

Miller Cylindrical*

Mollweide*

New Zealand Map Grid

Hotine Oblique Mercator 1pt

Polyconic

Robinson*

Sinusoidal*

Swiss Oblique Mercator

Stereographic Transverse Mercator

 

* Coordinate Systems using this projection will not be stored when saving the reference file.

Blue Marble Reference File (rsf)

The Blue Marble Reference Settings File saves the complete reference point list information such that it can be loaded again in the future. Within a Blue Marble Reference File, the first line contains the version of the file format (not to be confused with the version of the software) and the total number of points in the file. The remaining lines contain, in each line, the point ID, the x (row) pixel, the y (column) pixel, the z (elevation) value which is usually 0.00, followed by the ground coordinates expressed as Latitude or Northing (Y), Longitude or Easting (X) and Elevation (Z). The last value indicates whether the point described on that line is included in the solution, 0 = not included and 1 = included. Blue Marble Reference files support storing coordinate system information (all are supported).

ER Mapper File (ers)

The ER Mapper header file is an ASCII file describing the raster data in the data file. The entire header file holds information about the data source and is contained in the DatasetHeader block. There are two compulsory sub-blocks, the CoordinateSpace block (to define the coordinate space and location) and the RasterInfo block (to define the characteristics of the data in the accompanying data file). The RasterInfo block my contain a number of optional sub-blocks. To completely define coordinate information in an ER Mapper header file you need to include the following data: datum, projection, coordinate type, units, X and Y dimensions for cell size, registration cell X and Y values, registration cell coordinates, and possibly null cell value. Coordinate information is frequently, but not always, given for the upper left corner of an image. This would be registration cell X and Y values of 0.0 and 0.0.

For most projections registration coordinates are entered as eastings and northings, the coordinate type will be "EN", and units will be meters (or occasionally feet). If you are using latitude and longitude the projection is Geodetic, coordinate type will be "LL", and the X and Y dimensions for the cell size will be in decimal degrees.

 

ER Mapper files support storing a limited number of pre-defined coordinate systems. Check the coordinate system details to ensure the ER Mapper identifier exists as the issuer for the coordinate system to be saved. The file will still be exported however the coordinate system will not be saved with the reference file.

 

information ER Mapper reference files do not support rotated images. When attempting to export a reference file with a rotated image ER Mapper will not be listed.

ListGeo file (lgo)

A ListGeo files are text files containing the GeoTIFF metadata information (or tags), which can then be read, and may also be used as input to other programs.

GeoTIFF File (tif, tiff)

Tagged Image File Format (TIF or TIFF) is a common raster graphic file format and one of the most common geospatial image formats you are likely to come across. Many raster geographic images from GIS systems are stored in this format. A GeoTIFF is a TIFF file with embedded geographic information such as position and scale in world coordinates, coordinate system or an explicit list of ground control points.

 

information The only way to differentiate a regular TIFF image from a referenced GeoTIFF image is to open it in a spatial imaging software application (such as Avenza Geographic Imager).

 

Unlike the other geographically referenced image formats discussed in this section, GeoTIFFs do not require a separate reference file. When registering a GeoTIFF image in MAPublisher, the same file name must be selected in the Load File dialog box—the required georeference information is contained in the file header.

 

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area

Cassini-Soldner - Cassini

Cylindrical Equal Area

Equidistant Conic

Equidistant Cylindrical

Equirectangular

Gnomonic

Hotine Oblique Mercator

Laborde Oblique Mercator

Lambert Azimuthal Equal Area

Lambert Conic Conformal (1SP)

Lambert Conic Conformal (2SP)

Lambert Cylindrical Equal Area

Mercator

Miller Cylindrical

New Zealand Map Grid

Oblique Mercator

Oblique Stereographic

Orthographic

Polar Stereographic

Polyconic

Robinson

Sinusoidal

Stereographic

Transverse Mercator

Transverse Mercator (South Oriented)

VanDerGrinten

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 4/11/2019