MAPublisher contains ten different scale bar designs that may be incorporated into a map. After creation, MAPublisher scale bars can be subsequently resized using the bounding box (for example to add or remove component intervals). Scale bars can also be edited by selecting the Object > Edit Scale Bar menu item.

Requirements

To accurately create a scale bar, a MAP View must contain accurate georeferencing information and the coordinate system must be projected. (i.e. not in degrees). Scale bars are added on Legend layers. If no legend layer is present in the document, a new legend layer will be created automatically.  To manually create a new Legend layer, use the Add MAP Layer button on the MAP View panel and specify a feature type of Legend (see more about feature types).

If a custom character style is to be used for the labels of the Scale Bar, it is also advisable to establish this style (Window > Type > Character Styles) before opening this dialog box. Alternatively, use the Edit Text Rendition dialog box to specify the font, colour, size and style of text to use.

A scale bar cannot be created on a MAP View that contains a coordinate system using custom (user defined) point styles or units.

Add a Scale Bar

Click the Scale Bar button on the MAPublisher toolbar or choose Object > MAPublisher > Scale Bar.

General

Use the Scale Bar Style drop-down list to select a preset scale bar design. Note that some scale bar designs contain two bars and when such a design is selected, the Bottom Bar column of options is enabled.

 

Scale bar styles can be saved. Beside to the Scale Bar Style drop-down, click the Save button and enter a name. Saved scale bars are saved to a location specified in MAPublisher Preferences.

Click the Export Style button to export a scale bar style file (XML). These can be shared with other MAPublisher users. To import a scale bar style file, click the Import Style button and browse for the appropriate style file.

 

Click Restore Defaults to return scale bar styles to their default settings.

Appearance

Use the setting in the Appearance tab to control the style, bar level, spacing between double bars, and tick position. Fine tune bar height and tick height independently and adjust appearance including line or bar color, stroke thickness, and opacity.

scalebar_appearance

In the Scale Bar dialog box, click the Appearance link to change the scale bar appearance. The Scale Bar Appearance dialog box consists of settings to change the Main colour and Alternate colour, including opacity and stroke. An Overprint setting can be toggled so that overprinting can be turned on or off for Scale Bar elements during print. For double scale bars, there are separate appearance settings for top and bottom bar.

edit_scalebar_appearance

To adjust the height of the scale bar, edit the Height value. Changes are reflected in the preview.

After the scale bar has been created, use the bounding box of the generated scale bar (View > Show Bounding Box) to resize. Resizing scale bars horizontally will automatically add or remove intervals from it. Resizing vertically will adjust the width of the bars. Scale bars can also be resized using the Adobe Illustrator menu Object > Transform > Transform Each, by changing the horizontal or vertical scales.

To change the style of the scale bar or to modify any parameter without generating a new one, select the scale bar and click Scale Bar button on the MAP Toolbar. This will re-open the Scale Bar dialog box and the current parameters of the bar are available for editing.

 

Intervals

Use the settings in the Intervals tab to control the intervals and units of the scale bar.

scalebar_intervals

 

In the Units drop-down list, specify the units for the scale bar intervals to be based on. The default units are that of the current MAP View.

 

In the Interval text box, specify a real-world distance that each interval of the scale bar will represent. This number will be in the unit specified in the Units list.

 

Specify the number of cells in the scale bar by entering a number in the Number of labeled intervals scroll box.

 

Depending on the chosen style of scale bar, it may be required to specify the Number of horizontal lines that will compose the scale bar.

 

To subdivide some of the intervals or cells in the scale bar, specify a number in the Number of intervals to subdivide scroll box. The subdivided cells begin at the left side of the scale bar. The Number of sub-intervals that compose each of these cells can be specified in the next scroll box. As required, choose to Add an interval left of '0'.

Labels

Use the settings in the Intervals tab to control the intervals and units of the scale bar.

scalebar_labelstab

Click the Tick label appearance to adjust the tick labels of a scale bar in the Edit Text Rendition dialog box. Choose a predefined Character Style in the Graphic Style mode or set font, stroke and fill options in the Custom mode.

 

In Graphic Style mode, labels can be styled using predefined Adobe Illustrator Character Styles. Graphic Styles can be applied to these labels by choosing one from the Graphic style drop-down list. In Custom mode, labels can be styled using the font, font size, stroke, stroke width and fill options available. Click the toggle to switch between Graphic Style mode and Custom mode.

edit_text_appearance edit_text_appearance_character

Adjust the Tick label spacing to increase or decrease spacing between the tick label and the scale bar. The Display scale value option shows the scale value above and to the left of the scale bar (by default). The position and alignment can be changed using the respective drop-down lists. The Display page to map units ratio option adds the page unit to map unit ratio label (select from Inches, Centimeters and Millimeters). Use the decimal precision and placement options to adjust the appearance as necessary.

 

To further enhance the look of scale bar labels, click the Customize Labels button.

customize_labels

Under the Label Unit Overrides section, check the options to override the Page unit and World unit labels and type text into the text boxes. Under the Formatting section, click the Scale and Ratio appearance links to open the Edit Text Rendition dialog box (same as above) to adjust the font, color, size, stroke and fill of the scale and ratio labels. Type text into the Scale and Ratio label text boxes to specify custom labels along with using the available variables (e.g. %page_unit%). The variables represent stored values from the Scale Bar dialog box and the map document. A preview of the scale is shown below each of the text boxes.

 

Click OK to place the selected scale bar on the legend layer at a default position (centered on the artboard). The Adobe Illustrator editing tools may be used to move the scale bar to a desirable location.

 

information Manually editing a scale bar is not possible in its default grouped state. However, manual editing is still possible if the object is expanded first (Object > Expand). Note, that this will break the dynamic link between MAPublisher and the scale bar and it cannot be edited using the Scale Bar dialog box.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 10/10/2019