Working With Images

Import an image and switch it to another MAP View

1.Create a new Adobe Illustrator document in landscape mode Letter sized.

2.Import southchinasea.shp from the Tutorial Data folder.

3.Import borneo.tif from the Tutorial Data folder. If necessary, click Advanced to expand the dialog box.

import_image

Notice how the image doesn't have a coordinate system. You could enable the Same as check box and assign it the same coordinate system as the southchinasea MAP View. However, leave the Same as check box unchecked to see what would happen another way.

4.Click OK.

borneo

The raster image is placed at a default position and scale on the artboard. It is not aligned with the southchinasea_area layer because it does not have a coordinate system defined. Since the borneo MAP View wasn't provided with a coordinate system, you'll move the image to the southchinasea MAP View (and in the process, use the same coordinate system it already has). Note: This is an assumption that the image was originally created to have a WGS 84 coordinate system.

5.In the MAP Views panel, click and drag borneo_image MAP Layer to the southchinasea MAP View.

missingcoordinatesystem

6.Make sure the Same as drop-down list has southchinasea chosen and click OK.

7. When prompted, click Move image layer.

confirmmoveimage

The image is registered; its size and position have been changed to reflect the information in the reference file. Note that one of the major assumptions about the image is that it is already in the WGS 84 coordinate system.

imageregistered

information Alternatively, this exercise can be completed using File > Place to place an image on any layer and then using Register Image to provide the appropriate coordinate values.

8. Leave the document open for the next tutorial.

Register an image without a reference file

This method is useful if no reference file is available. However, it is necessary to know the coordinates for one of the corners of the image as well as the pixel scale in order to register the image correctly. That information is provided for you in this tutorial.

9. Select and delete the existing Borneo image, but leave the Borneo image layer in the document.

10. With the Borneo image layer highlighted, in the Adobe Illustrator menu, click File > Place, navigate to the Tutorial Data folder, select the sample raster image file, borneo.tif, and click Place. The raster image can be placed anywhere on the artboard.

11. With the image selected, click the Register Image button on the MAPublisher toolbar.

12. Click the Upper Left Placement (top left corner of the blue diagram) and type the following values into the Upper Left Placement X and Y boxes: X=108.3375605, Y=7.7816585.

13. For the Image Size X box, type 0.012773 deg. Make sure that Constrain proportions option is checked.

registerimage2

14. Make sure the dialog box matches above and click OK.

imageregistered

The image is registered to the selected layer. The upper-left corner of the image is what MAPublisher used as the raster anchor point.

15. Leave the document open for the next tutorial.

Export a placed image as a georeferenced raster file

A referenced image must be placed on an Image layer in order to export it.

16. With the Borneo image selected, click Export > Export Selected Image from the MAPublisher Toolbar.

17. In the Export Selected Image dialog box, select GeoTIFF from the Reference format drop-down list to set the georeferencing output format.

18. Click Browse and navigate to a location to save the export image. Type MyBorneo.tif into the File name box and click Save.

exportselectedimage

19. Click OK to complete the export process.

The image of Borneo is exported as a GeoTIFF file using the coordinate system of the southchinasea layer.

20. Close the document without saving.

Copyright © 1995-2020 Avenza Systems. All rights reserved.

 

Last updated: 4/12/2019